Ubuntu 18.10@ThinkPad A285 で Wi-Fi が使えない問題

どうやらカーネルのバージョンが上がった際に使えなくなってしまったらしい
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1806472

回避策:とりあえず古いカーネルを使う

yutaro@a285:~$ sudo grep “menuentry.*generic'” /boot/grub/grub.cfg
menuentry ‘Ubuntu, with Linux 4.18.0-13-generic’ –class ubuntu –class gnu-linux –class gnu –class os $menuentry_id_option ‘gnulinux-4.18.0-13-generic-advanced-186f8722-6db8-4539-8f94-2af95b2bad7e’ {
menuentry ‘Ubuntu, with Linux 4.18.0-11-generic’ –class ubuntu –class gnu-linux –class gnu –class os $menuentry_id_option ‘gnulinux-4.18.0-11-generic-advanced-186f8722-6db8-4539-8f94-2af95b2bad7e’ {
menuentry ‘Ubuntu, with Linux 4.18.0-10-generic’ –class ubuntu –class gnu-linux –class gnu –class os $menuentry_id_option ‘gnulinux-4.18.0-10-generic-advanced-186f8722-6db8-4539-8f94-2af95b2bad7e’ {

GRUB_DEFAULT で起動する古いカーネルを指定する

yutaro@a285:~$ sudo vi /etc/default/grub

GRUB_DEFAULT=”Advanced options for Ubuntu>Ubuntu, with Linux 4.18.0-10-generic”

grub.cfg を生成する

yutaro@a285:~$ sudo update-grub

シャットダウンして起動する